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Introduction

Introduction

To assist our customers, GRAPHISOFT has developed a new IFC Workflow Guide document. The
purpose of the IFC Workflow Guide is to explain in simple terms the recommended IFC workflows
between ARCHICAD and Revit.

The workflows cover conversion between ARCHICAD and REVIT Architecture, Structure and MEP. An
intermediate knowledge of both ARCHICAD and REVIT is a prerequisite for understanding of this
guide.

We believe that having a standard approach in interoperability exchange situations will allow better
training materials to be developed and in time also allow companies to employ staff without the
need to retrain them.

Compatibility

This workflow guide was completed in January 2017. Graphisoft is planning to continuously update
the document and it will be available via Help Center quides.

The software versions installed are:

ARCHICAD 20, update 4020
http://www.GRAPHISOFT.com/downloads/

GRAPHISOFT’s ARCHICAD Connection for Revit Add-In 4538
http://www.GRAPHISOFT.com/downloads/interoperability.html!

Latest Service Pack for Revit

https://knowledge.autodesk.com/support/revit-products/downloads

Autodesk’s IFC import-export app for Revit

https://sourceforge.net/projects/ifcexporter/

Reference Model Concept

The workflows described in this article operate under a concept called the ‘Reference Model
Concept’ which is mainly a one-directional exchange. If modifications are required to a particular
model not owned by the user, then these modifications must be handled by the original author of
that model.

Each stakeholder of a project is legally responsible for their own work, so do not modify anything on
any model you do not own.

For further information, please read Building Smart’s definition of the reference Model Concept:
http://www.buildingsmart-tech.org/specifications/ifc-view-definition/ifc4-reference-view
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Introduction

Additional resources

Help Center guides on Interoperability

http://helpcenter. GRAPHISOFT.com/quides/archicad-20/archicad-20-reference-quide/
interoperability/#1233956

Help Center Troubleshooting Guide for IFC based data exchange

http://helpcenter. GRAPHISOFT.com/troubleshooting/import-export/troubleshooting-quide-for-ifc-
based-data-exchange-2/

Help Center OPEN BIM videos
http://helpcenter. GRAPHISOFT.com/videos/archicad/open-bim/

Help Center Tips and Tricks/OPEN BIM
http://helpcenter. GRAPHISOFT.com/tips/open-bim/
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ARCHICAD Model Setup for IFC Export to Revit

ARCHICAD Model Setup for IFC Export
to Revit

Basics

Coordinate among Project Stakeholders

Most projects that encounter troubles later on, do so, because of the lack of preliminary
coordination! Organize a BIM Coordination meeting to agree upon the following:

e project location and coordinates

¢ Project North direction

e Story setup

Vi

./

[ >

\41/ >/
(3) Story Settings

No.Name Elevation Height to Next = ==

2 6200 3100 ™
1 3100 3100

0 Ground Floor 0 3100 4]

Prepare a BIM Manual and share it with all the stakeholders. The BIM Manual should include:
¢ the stakeholders and their exact responsibilities

¢ the data exchange protocol

¢ the data agreed upon at the BIM coordination meeting

¢ project specific BIM requirements

IFC Exchange Best Practices 7



ARCHICAD Model Setup for IFC Export to Revit

Set Element Parameters

e Define the Structural Function of the element

¢ Set the Position of the element within your project

¢ Set the IFC Classification of your element

¢ Enable the necessary IFC properties for the element or create mapping rules

(see Data Mapping in the IFC Reference Guide at http://helpcenter. GRAPHISOFT.com/?p=55687)

® Column Default Settings
ifr Default
v §! GEOMETRY AND POSITIONING
Column Top: E}I S0 E
1. St H 1 =
ovvone- B EHOE
y -200 [J ceneric - sTRUCTURAL >
g> B
; 0o >
Home Story:
0. Ground Floor (Current) B D_ ﬂ [
L L & 0.00°
to Project Zero > Anchor Point of Core: -y
i $ed
- e
- FLOOR PLAN AND SECTION
v (§ mopEL
Override Surface:
5 O
Custom Texture Alignment: Reset Texture
Relation To Zones: Zone Boundary

v CATEGORIES AND PROPERTIES

Element Classification: >

v ID AND CATEGORIES
1D CRE - 001
Structural Function Load-Bearing Element
Position Exterior [>]

v RENOVATION use Palette to set default
Renovation Status
Show On Renovatio..

@ Structural - Bearing > Cancel “

Organize Elements

¢ Make sure all project elements are assigned to proper layers.
This will enable you to easily hide elements that you do not wish to include in the IFC.

IFC Exchange Best Practices 8



ARCHICAD Model Setup for IFC Export to Revit

Hide all layers that do not contain elements relevant to your consultant receiving the IFC.
(For example: signage, furniture, vegetation)

Create a layer combination from the step above.

Save a 3D view of your project that uses the previously created layer combination.

This will allow you to easily switch to a view from which you can save your IFC.

Coordinates and Orientation

Create the ARCHICAD model close to the ARCHICAD origin, which is indicated by a black cross on
the floor plan. Loss of precision or malfunction can be experienced if the project elements are
located very far from the project origin or from each other

Create the ARCHICAD model orthogonally.

x(— ARCHICAD ORIGIN 0,0,0

Coordinates and Orientation — Real World (option1)

To export an ARCHICAD IFC model to a real world location for it to be imported into an analysis
application (Navisworks, Solibri) we recommend the following:

1.

Set up a new ARCHICAD file which contains the site situated at real world coordinates. Also set
up the stories’ Elevation values to the real world Z coordinate.

See Stories/Levels — Real World (option1) for more info.

2.

Take the building model we created earlier which is situated at 0,0,0, and hotlink it into the site
model.

Drag the hotlink module to the desired X/Y position.
Rotate the hotlink module to the correct orientation (Angle to True North)

Export to IFC with the IFC Site location option set to ‘At Project Origin’. This option is at IFC
Translator > Export Options > Geometry Conversion Options.

IFC Exchange Best Practices 9



ARCHICAD Model Setup for IFC Export to Revit

IFC Site geometry: ’ BREP V‘
IFC Site location (if Survey Point is available): l At Project Origin v‘

Coordinates and Orientation — Real World (option2)

Starting with ARCHICAD 20, the Survey Point definition and it’s export and import with IFC models is
supported. It is recommended to use a common anchor/reference point (so-called “Survey Point”)
to facilitate coordination of models from different programs. In some countries, the use of a
particular reference point (national datum) is a standard requirement when defining the project.

1. Use the survey point if a common point is agreed among all project stakeholders and they will all

be using the survey point object!

In ARCHICAD 20 the survey point is part of the ARCHICAD Built-in Libraries
In the survey point settings, set the “Project North” and coordinate the “Project North” among

all disciplines!

4. Export the IFC with IFC site location at survey point position setting.

IFC Site location (if Survey Point is avallable): v X: 5609673
spY: 126.811
& Z: 100.000

Survey Point = IFC [0; O; O] = IFC Site Location

Stories/Levels

e Set up the ARCHICAD stories.

fA Story Settings ? X
No. Name Elevation Heightto Next = =
®  2RFRoof 6000 3000
. 1 01-First Floor 3000 3000
[GF-Ground Floo Io J3000
Insert Above Insert Below Delete Story

IFC Exchange Best Practices
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ARCHICAD Model Setup for IFC Export to Revit

¢ For the story setup, coordinate with the other stakeholders.
¢ The screenshot below shows a typical coordinated story setup.

@ Story Settings

No. Name Elevation Heightto Next = w
L] 7 Structural level 20000 4000 ™
® 6 Offices 17000 3000 )
° 5 Upper Concourse 13000 4000 ™
[ ] 4 Diagnostics and HVAC level 10000 3000 ™
° 3 Lower concourse 6000 4000 ™
° 2 Gallery level 3000 3000 ™
° 1 Entry/Parking level 0 3000 ™
G Parking level |-3000 3000 I

Insert Above Insert Below Delete Story

Stories/Levels — Real World (option1)

e Set the ARCHICAD elevation values in the site model to the real world Z coordinate.

e Keep the Height to Next values the same. When the building model at ARCHICAD origin is
hotlinked, it will simply be elevated to the new heights specified in the site file.

fA Story Settings g X
No. Name Elevation Heightto Next = =
® 2 RF-Roof 26000 3000
. 1 01-First Floor 23000 3000
[ 0[GF-Ground Flood] J20000 [3000
.
Insert Above Insert Below Delete Story

e

IFC Exchange Best Practices 11



ARCHICAD Model Setup for IFC Export to Revit

Stories/Levels — Real World (option2)

This option goes with Coordinates and Orientation — Real World (option2), if a Survey Point is used.
(Since the survey point is used, there is no need for hotlinking the model.)

Set the ARCHICAD elevation values in your model to the real world Z coordinates and keep the
Height to Next values the same. At export the IFC will be exported to Real World Z coordinates.

Zones

¢ Model the ARCHICAD zones with the inner edge construction method.

¢ Manual zones are time consuming to create and cannot be updated via the Update Zones
command (Design Menu > Update Zones) which may also lead to inaccuracies for area
calculation/zone calculation within ARCHICAD’s scheduling environment.

¢ Manual zones can also cause import errors for Revit users in which the converted ARCHICAD
zones may be reported as ‘room is not in a properly enclosed region’

Main Layer Construction Method Zone Name And Number:
Name:| <zone name> »
Defauit Settings v A-Zz_50_95_Z Int: I . T _
| Default Sett: [Zh [ oneinternal »| | [~ ¥ [ff [:T P
¢ |If exporting an IFC to Revit, ensure that the subfloor thickness value of the ARCHICAD zone is set
to Omm. We’ve come across an issue where if a subfloor thickness is defined, it can cause the
Revit error: ‘room is not in a properly enclosed region’.

e Zones are exported from ARCHICAD as BREP by default, yet the zone type information stays
intact. When the zones are reopened from an IFC file, they will be imported as native Zones to
ARCHICAD.

¢ If the zones have SEO-s acting on them, the operators will be placed on a separate layer upon IFC
import. If you move the zone, consider making the operator layer visible as well.
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ARCHICAD Model Setup for IFC Export to Revit

|
v NAME AND POSITIONING

Category: Generic D >

Name: Zone No: 02

Zone Top:

1. Story (Home + 1) v
Zone Polygon:

— =iy

Subfloor Gross
Thickness: SJINot
100 e
_* 0
Zone Stamp Angle:
Home Story: Relative >
0. Ground Floor (Current) '\a@d 0,00°

to Project Zero >

: —& W Fixed Angle
-— | 100

¢ For rooms that are not bounded by walls, use the line tool and set it to act as a zone boundary.
That way you can place zones using the inner edge construction method.
"4 Line Default Settings ? X
w Default
[J uniform Settings for Line Tools

~ 7. GENERAL SETTINGS

lid Li 1

Solid Line " _y | .
Mzone Boundavl

§/ *-/ 4/'l *f 2.00 mm 1 i

v @ CATEGORIES AND PROPERTIES

2 ID AND CATEGORIES
Line Category Drafting Line
v RENOVATION use Palette to set default
t tat Existing
All Relevant Filters
& A-Z2.80_45_LinesArcs . Cancel
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ARCHICAD Model Setup for IFC Export to Revit

General Modeling Tips

¢ Save only the levels that will be a part of the building.

¢ Stories should not be used as space for sketches or as a temporary storage for alternative design
solutions.

e Consider and import levels that other disciplines use.

¢ Check all floor heights to other disciplines’ models before the exchange of information takes
place.

¢ Find out how other disciplines’ applications handle levels.

¢ You can introduce quality control measures using graphic overrides or the Interactive Schedule,
e.g. for erroneous geometries or missing data.

Common Mistakes

¢ The entire model is placed far from the origin.

¢ Data that are no longer required remain in the model. Also, there may be wall pieces, slabs or
objects that have accidentally ended up far from the origin.

¢ A combination of the above, where both model and building components are located far from
the origin.

¢ The model contains too many objects with complex geometry. E.g. 500 seating objects with
detailed armrests, headrests and wheels, or 1000 detailed doors with locks and handles on both
sides.

¢ Incorrect settings in, or incorrect use of the IFC translator: for example, all the properties of
objects in the library are set to Custom Property Set. This setting comprises a huge amount of
data, of which a large part is completely unnecessary. Be specific and consistent with the
project’s IFC properties.

¥ EXPORT OPTIONS

Elements to export: Visible elements (on all stories) [C ]
IFC Schema: IFC2x3 [T
IFC Model View Definition: Coordination View Version 2.0 &

Name of custom extended view:

Properties to export: All IFC properties [

Geometry conversion Conversion Options...

Building Information data to export Data Settings...

IFC model units Units Settings...

IFC Global Unique Identifier attribute (Globalld): Keep ARCHICAD IFC ID (recommended) [
Revert Changes Cancel Save Settings & Close

IFC Exchange Best Practices 14



ARCHICAD IFC Translators

ARCHICAD IFC Translators

Importing and exporting model data using IFC is controlled by the settings of the translator you are
using. ARCHICAD provides predefined, factory-default IFC Translators, but you can define your
own. IFC Translation Setup command (File > Interoperability > IFC) allows you to view or modify
translator settings, or to create new translators. The following is a description of the settings found
in the IFC Translator Setup dialog box:

4 IFC Translation Setup ? X
AVAILABLE TRANSLATORS

Name « Project Partner Create New...
BiMaYou 4D/5D
COBie 2 Export coBie Duplicate

=5 Concept Design BIM 2010 Export GSA Refiame
Data Exchange with AECOsim Building Design Structural
Data Exchange with Allplan Engineering Structural Delete
Data Exchange with Analysis Applications Structural Broweas

© Data Exchange with DDS-CAD MEP MEP
Data Exchange with Plancal nova MEP
Data Exchange with Revit MEP MEP
Data Exchange with Revit Structure Structural
Data Exchange with Scia Engineer Structural
Data Exchange with Tekla Structures Structural
Exact Geometry Export General
Exact Geometry Import General

3 O 9%  General Translator General

IFC4 Design Transfer View General
IFC4 Reference View General
Import from Modeling Applications Modeling
iTWO Export M

d Reference Model Export to Revit General

Location: C:\Users\hgillbite.co. uk\GRAPHISOFT\IFC Tr 5 20.0.0 INT\ I Tr xml

» DESCRIPTION

* IMPORT/EXPORT FILTER OPTIONS
* IMPORT OPTIONS

» EXPORT OPTIONS

Revert Changes Cancel Save Settings & Close

For more information, please read the following Help Center article:
http://helpcenter.qraphisoft.com/?p=61045
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ARCHICAD IFC Translators

ARCHICAD IFC Translator Setup for IFC
Export to Revit Structures

A Geometry Conversion Options ? X
E‘ Use BREP geometry in current color for all elements I
Create New...
[ explode Composite and Complex Profile elements into parts | Duplicate
2] Export geometries that “Participates in Collision Detection” only Rename...
Delete
Browse.
De
geo
IFC Site geometry. BREP
IFC Site location (if Survey Point is available): At Project Origin

(D Note: Some options are not available, c . i
due to the current Model View Definition. a0t .

~ IMPORT/EXPORT FILTER OPTIONS

Filter Model Elements to Convert by

IFC Domain: Al v Options...

Structural Function: All elements
[C] Convert IFC Annotations and ARCHICAD 20 elements
[4] Convert Grid elements
[ Convert 2D symbols of Doors and Windows

* IMPORT OPTIONS
~ EXPORT OPTIONS

Elements to export: Visible elements (on all stories)
IFC Schema: IFC2x3
IFC Model View Definition: Coordination View Version 2.0

Name of custom extended view:

Properties to export: All IFC properties
Geometry conversion l Conversion Options... l
Building Information data to export Data Settings...
IFC model units Units Settings...
IFC Global Unique Identifier attribute (Globalld): Keep ARCHICAD IFC 1D (recommended)
Revert Changes Cancel Save Settings & Close

Above is a recommended IFC Translator Export setup when issuing models to Revit (or other design
applications). The key option here is ‘Use BREP geometry in current color for all elements’ within
Geometry Conversion Options.

For further information, please read Pages 2492-2506 within the ARCHICAD 20 Reference Guide or
follow the link to the Helpcenter related article: http://helpcenter. GRAPHISOFT.com/?p=62997
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ARCHICAD IFC Translator Setup for IFC
Import to ARCHICAD

To import an IFC file into ARCHICAD, navigate to the File > Open. (If you already have a project
running, check the option “launch a new instance of ARCHICAD"”).

Prior to importing the IFC file, you must decide how to import the geometry/attributes of the IFC
file. This is governed by the IFC Translator - Import options.

The screenshot below shows the default Data Exchange with Revit Structure IFC Translator.

A& Geometry Conversion Options 7 X

Building elements: | Construction elements, otherwise Objects

Distribution elements: | MEP Elements, otherwise Objects v ate New...

Other elements: | Objects - uplicate

EA1FC site geometry: Morphs . ename..

Unnamed IFC profiles: Custom profiles Delete
rowse...

Location: CAUsers\hgilibite.co.uk\GRAPHISOFTUFC Transiators 20.0.0 UKN\Data Exchange with Revit Structure.xmi

» DESCRIPTION
» IMPORT/EXPORT FILTER OPTIONS
~ IMPORT OPTIONS

A show Model Filter on import

Geometry Conversion I !onvmuon Spl.ons‘.‘ I

Layer Conversion

(O Keep original layers
(®) Keep original layers and add extension: ®/ | Revit Structure
(O Place elements on one layer. Model from Revit Structure

Material and Surface Conversion

Material import method for IFC Materials: Create attributes from IFC Materials
[ use material mapping Material Mapping...
Buiiding Material for non-mapped materials: (O concepr ’

[ Generate Surface Attributes from IFC geometry Surface overrides

Renovation Status Conversion

Replace missing Renovation Status with: New
* EXPORT OPTIONS

Revert Changes Cancel Save Settings & Close

Tip: The benefit of using File > Open over Merge is that you can first check the story setup of the
IFC Model.

IFC Exchange Best Practices 17



ARCHICAD IFC Translators

IFC Translator Settings for IFC Import to
ARCHICAD

Geometry Conversion Methodology

Native Element Import

Advantages

e Correct floor plan and section representation.
Disadvantages

¢ Creates complex profile attributes.
e Attributes will need to be managed carefully when revised IFC files are imported.

For more information, see Managing Attributes from Imported IFCs.

¢ Imported Complex Profiles may cause conflicts with attributes that already exist in the
ARCHICAD file.
e Complicated element connections may fragment when imported into ARCHICAD.

The screenshot below shows a complicated connection from Tekla in which, when the construction
elements are converted into native ARCHICAD elements (Beams), the connection breaks.

Morphs

Advantages
e Good control over 2D representation - (Projected, Projected with overhead, etc)

IFC Exchange Best Practices 18



ARCHICAD IFC Translators

¢ No complex profile attributes are created
¢ No library parts are created
e Complicated element connections will be left intact, creating precise geometry.

The screenshot below shows the same complicated element connection from Tekla, but the
elements have been converted to Morphs. As you can see, the geometry has been left intact,

creating precise geometry.
Disadvantages

* May become heavier than objects (slow performance in 3D)
e 2D representation for other construction elements (Walls/Slabs/etc) may suffer

Objects

Advantages

¢ No complex profile attributes are created.

® Objects can be stored in Linked Libraries or. Icfs for easier management.

e Complicated element connections will be left intact, creating precise geometry.
Disadvantages

e Itis difficult to control the 2D representation.

e There may be issues with objects not showing on the correct stories.

IFC Exchange Best Practices
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ARCHICAD IFC Translators

Geometry Conversion Options

@ Geometry Conversion Options
Building elements:
Distribution elements:
Other elements:
FC Site geometry

Unnamed IFC profiles:

Cancel

First, let’s consider how geometry conversion from a structural IFC model is handled. The primary
setting here is the Building elements option within the IFC Translator — Import Options — Geometry
Conversion Options.

The following options are available:

¢ Construction elements, otherwise Morphs
¢ Construction elements, otherwise Objects
¢ Morphs

¢ Objects

From a structural IFC model, the construction elements would be, Beams/Columns/Slabs/Walls/
etc.

Construction Elements, otherwise Morphs

The screenshot below shows a structural IFC imported into ARCHICAD.

The construction elements here are Beams and Columns, so these elements will be converted into
native ARCHICAD Beams and Columns. However, the Castellated Beam will be converted into a
Morph, due to the complexity of the element.

IFC Exchange Best Practices 20



ARCHICAD IFC Translators

Construction Elements, otherwise Objects

Native AC Columns

Imports in a similar way to “Construction elements, otherwise Morphs”, but the complex elements

(castellated beam) will be converted into objects. The standard beams and columns will be

converted into native ARCHICAD elements.

Native AC Columns

IFC Exchange Best Practices
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ARCHICAD IFC Translators

Morphs

The screenshot below shows the same structural IFC imported into ARCHICAD. This time, however,
all construction elements have been converted to Morphs.

Morphs

Objects

Imports in a similar way to Morphs, but all construction elements will be converted into Objects.

Tips

Even though we convert all construction elements to Morphs/Objects, the elements are left
intact.

IFC Data (Property Sets/Properties) are also left intact during the construction element
conversion to Morphs/Objects.

If importing an MEP model, use the “Objects” translator option, since the MEP objects will take
up much less memory if ARCHICAD can import them as native MEP objects. (MEP Modeler must
be installed.)

If, for a specific reason, native element conversion is necessary, it is possible to switch off the
Priority Based Connections in the IFC file, by changing the used layers' layer priority to O.

If the IFC file’s Site is too large, it can cause problems during IFC import. In this case, uncheck the
IFC Site geometry option.

For more info, please see this link: http://helpcenter.qraphisoft.com/quides/archicad-20/
collaboration-quide-for-archicad-20/coordination_with_engineers/mep_design/

graphisoft_ mep _modeler/

IFC Exchange Best Practices
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ARCHICAD IFC Translators

Layer Conversion

We recommend using the following setup for Layer Conversion:

Layer Conversion
(O Keep original fayers
(® Keep original layers and add extension: Revit Structure]
(O Place elements on one layer: Model fr Revit Structure
¢ The main option here is ‘Keep original layers and add extension’ This will import the layers

stored in the IFC, but ARCHICAD will add an extension (which can be edited) to all imported IFC
layers, allowing for easier management of IFC Layers and ARCHICAD model layers.

e However, if national standard compliant layer naming is used as the discipline code (that is the
code at the beginning of each layer name), it will help to differentiate the layers between the
Structural Engineer and the Architect.

Material and Surface Conversion

Material and Surface Conversion is a personal preference, but can be useful to avoid adding Building
Materials to the ARCHICAD model.

Material and Surface Conversion

Material import method for IFC Materials: [Oven.de with Building Materials ﬂ

Use material mapping
Building Material for non-mapped materials: [ GENERIC - STRUCTURAL >

Generate Surface Attributes from IFC geometry Surface overrides

You can read more about the Material and Surface Conversion on pages 2487-2491 of the
ARCHICAD 20 Reference Guide or read the corresponding chapter of the Helpcenter article: http.//
helpcenter. GRAPHISOFT.com/?p=62997
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IFC Import to ARCHICAD

IFC Import to ARCHICAD

IFC Import to ARCHICAD Workflow

1. File Menu > Open > Choose IFC Translator > Open .IFC Model.
2. Create a. Icf (if the IFC Model contains objects)

A Library Parts Location ? b’
Save Library Parts generated during import to:
(O Embedded Library
(® Linked Library

C\Users\hgillbite.co.uk\Documents

I{ﬂ Create Library Container File (.Icf)1

Note: These settings can be changed in IFC Options.

[[]Don’t show this dialog again Cancel oK

3. Save the imported IFC file as a PLN.

4. Additional step for Teamwork users: first remove the. Icf via Library Manager (File > Libraries
and Objects > Library Manager) and then upload the. Icf as a BIM Server Library (File> Libraries
and Objects > Manage BIMcloud/BIM Server Libraries). Add the BIM Server Library to the main
ARCHICAD project.

5. Hotlink the PLN which contains the IFC Model into the main ARHICAD model.

IFC Import Workflow for Revised IFC Models

1. Use Hotlink Manager to delete the original IFC Model hotlink PLN. (File > External Content >
Hotlink Manager)

2. Remove the current. Icf from Library Manager.

3. If new attributes (e.g. profiles) associated with the previous hotlink were created in the main file
at the time of translation, remove these attributes. (This can happen if you chose to convert
construction elements to construction elements - native conversion).

4. Repeat the steps from 1to 5 above.

Tips

¢ Never use the Merge command to import an IFC Model into the main ARCHICAD model. The
benefit of using File > Open over Merge is that you can first check the story setup of the IFC
Model.
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¢ Do not store Library Parts in the Embedded Library, especially for Teamwork projects. Adding
hundreds of .gsm files to the Embedded Library can cause Teamwork performance issues.

Managing Attributes from Imported IFCs

Introduction

When an IFC is imported and you choose the option 'convert to construction elements, otherwise
objects/morphs', then new attributes will be created in ARCHICAD. If the imported content is an IFC
structural file, the newly created attributes will consist mostly of complex profiles and Building
Materials.

IFC Profiles
= & 0
= & o
s ¢ o
= & 0
" IFC Profiles
e & o
" = & o
" s ¢ o
[ & = ¢ 0
Purge Unused Revert Print to Fie. e

The original smitutes Rave baen saved inks tha i Unttied_3_21_3010 4_10 FM aat Cancel o

How to Manage Complex Profile Attributes

When placing a revised IFC model, it is good practice to remove the previously created attributes
(e.g. complex profiles) However, if the project uses some of ARCHICAD's standard steels (Options >
Complex Profiles > Import Standard Steel Profile), the user might not necessarily know which are
the imported IFC profiles and which are the ARCHICAD imported profiles.

These tips can make it easier to manage attributes:

1. Prefix all ARCHICAD standard steel profiles (if they are in use): for example
GSUK_UC254x254x89. This way, the attribute name will tell you which are imported IFC Profiles
(No prefix) and which are standard AC profiles. This naming convention can also avoid another
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common problem: if profiles of the same name are loaded, the steels can rotate to a different
position. For example, an | beam becomes a H beam.

Make sure that the complex profiles list is fully populated in terms of their numbers. In the
screenshot above, profile #2 was missing. After IFC import, a new IFC profile was placed into the
#2 slot. In a large project, it may be difficult to find and remove this profile later, in case of the
revised IFC Import. To fill in the gaps and avoid this, | recommend creating a ‘"dummy' complex
profile attribute file in which all dummy profiles are numbered correctly. You can then load this
dummy attribute file into the main project via Attribute Manager (Options > Element Attributes
> Attribute Manager) and use the <<By Index button to load these profiles to populate the gaps.
When you next import the IFC, all newly imported profiles will be placed together, at the end of
the list of complex profiles.

For example:

36 profiles loaded into a project. When the IFC is imported, | can now easily see that anything after

profile 36 is an IFC profile.

'y
s @ = |V = X

Profiles.
Attributes of the current project: Untitied Current File: Untitled aat

Anything created
after profile 36 is
an IFC Complex
Profile

LRI
0000C0ODODOOO

Revert
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Tips

For structural imports, we recommend importing the .ifc converted to Morphs. For one thing, as an
Architect you would not require the structural elements to be native. For another, the benefit of not
having to manage attributes/libraries makes it easier to manage revised IFC models.
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IFC Translator Conversion Settings for
IFC Export

Geometry Conversion Methodology

What is BREP?

BREP is short for Boundary Representation. A BREP reproduces the precise geometry when
exporting IFC files. BREP geometries will include Solid Element Operations, Trims, Crops, etc from
the ARCHICAD model.

Limitations of BREP

¢ Non editable elements (object based)
e Some parameters are lost
Example of an ARCHICAD IFC exported as BREP (Revit 2016).
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Extruded/Revolved Geometries

Example of an ARCHICAD IFC exported as Extruded/Revolved geometries (Revit 2016). With the
extruded/revolved geometry method, elements edited with Solid Element Operations will be
exported according to their original definition geometry — as for example on this image.

28
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Revit Structural Model Setup for IFC
Export to ARCHICAD

Coordinates and Orientation

¢ Create the Revit model close to the Project Base Point (indicated as a circle with a cross through
it).
¢ Create the Revit model orthogonally.

® € Project Base Point

Tips

¢ The Project Base Point may be hidden by default. To show it at all times, press VG to open the
Visibility/Graphic Overrides settings. Then navigate to the Site subheading, followed by Project
Base Point. Check the box to show the Project Base Point.

¢ The Project Base Point is equal to ARCHICAD’s origin (black cross — 0,0,0)

¢ Do not move the Project Base Point from its start-up location, as this will cause differences in
origin placement between Revit and ARCHICAD. To check if the Project Base Point has been
moved from its start-up location, unclip the Project Base Point, then click “Move to Start-up
Location” from the context menu.

Coordinates and Orientation — Real World (option1)

To export the Revit IFC model to a real world location, for import into an analysis application
(Navisworks, Solibri), we recommend the following:
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e Add the agreed X/Y/Z positions to the Project Base Point.

Project Base Pont
A Shared Site
N/S 179207239.0
@ EW 539722955.0
Elev 20000.0

® EXngk: to True North 0.000°

e Export the Revit model to IFC using the GRAPHISOFT Add-In with the following options checked:

Tips

IFC Export Options X

Phase to export: | New Construction
Level of detail for some element geometry: | High v

Export only elements visible in view
[] Export rooms in 3D views
Export Shared Coordinate System components to IFC Site:
[A N/S and EMW positions
Elevation
Angle to True North
[[] Export annotation elements
[[] Selit walls, columns and duct segments by level
[[] Export parts as building elements
[[] Allow use of mixed "Solid Model” representation
[[] Export internal IFC property sets
[[] Export schedules as property sets
[T] Export Family and Type name as Reference property

[k ] | Conce

¢ The Revit model will be exported to the correct real world location as defined by the Project
Base Point if you check the following options:

e N/S and E/W positions

e Elevation

¢ Angle to True North

¢ If you are viewing the Revit model in a floor plan view and you have checked the option ‘Export
only elements visible in view’, only one story will be exported. Therefore, use this option only

from a 3D View.
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Coordinates and Orientation — Real World (option2)

1. Use the survey point if a common point is agreed among all project stakeholders and they will all
be using the survey point object!

2. In Revit the Survey Point may be hidden by default, you can choose to make the Survey Point
visible by pressing VG visibility graphic override settings then under the site subheading you will
find the option to make both the Survey Point and Project Base Point visible.

3. Inthe Project Base Point settings, set the “Angle to True North” and coordinate the same angle
among all disciplines!

4. The IFC export options should be the same as in option1.

Stories/Levels

¢ Set the Revit Levels so that they are calculated from O.

¢ Prior to exporting an IFC file from Revit, make sure all additional structural levels (TOS, TOC,
TOB, etc) are not set as Building Story. Secondly, add additional Levels to match the agreed level
structure on the BEP and set these to be Building Story.

¢ To turn off additional structural levels, open up a section/elevation view, then highlight the level
you do not wish to export, and uncheck the Building Story option within the Properties
dialogue.

¢ Only the defined levels in the BEP should have the option Building Story checked.

Level 2 FFL 4
7550 W

Upper Level 2 TOS
6950 -

B

Level 2 TOS. g
6400 W

¢ Additional levels for Finish Floor Levels can be added without affecting geometry positions in
Revit. To add additional levels to coordinate with ARCHICAD users, open up a section/elevation
view and navigate to the Structure tab on the ribbon, followed by level.

Stories/Levels — Real World

As mentioned earlier, similar to the Stories/Levels — Real World (option2) defining an elevation value
within Project Base Point will export the model to the real world Z height, provided that the
Elevation option is checked within the GRAPHISOFT Revit Add-In.
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(with Add-in)

Before exporting a Revit model to IFC, please ensure that the following plugins/updates are
installed:

GRAPHISOFT’s ARCHICAD Connection for Revit Add-In
http://Www.GRAPHISOFT.com/downloads/interoperability.html!

Autodesk’s IFC import-export app for Revit
https://sourceforge.net/projects/ifcexporter/

Latest Service Pack for Revit

https://knowledge.autodesk.com/support/revit-products/downloads

Note: It is recommended to always use the GRAPHISOFT ARCHICAD connection for Revit Add-In
for both export/import of IFC files from Revit.

GRAPHISOFT’s ARCHICAD Connection for
Revit Add-In Setup

Once installed, the GRAPHISOFT Add-In can be located on the ribbon under Add-Ins.
g,laaf.t:;- SR 2 OA B0 F il

Architecture  Structure  Systems Insert  Annotate  Analyze Massing & Site  Collaborate  View Manage  Add-Ins  Modify

8| L O

Modify| Improved Link Exportto Help
IFCImport IFC ARCHICAD

Select « ARCHICAD Connection ~
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If or when both the Revit Architectural model and ARCHICAD model are coordinated near the
project origin (0,0,0), we recommend leaving the following options unchecked:

IFC Export Options X
Phase to export: Default Phase to Export v
Level of detail for some element geomety: Low v

[] Export only elements visible in view

Export Shared Coordinate System components to [FC Site:

[C] N/S and EAW positions

[] Angle to True North
[] Export annotation elements
[] Split walls, columns and duct segments by level
[] Export parts as building elements
[] Allow use of mixed "Solid Model" representation
[[] Export intemal IFC property sets
[[] Export schedules as property sets
[] Export Family and Type name as Reference property

Cancel

Tips

¢ We only recommend checking the options under “Export Shared Coordinate System
components to IFC Site” when models are required to be federated at global coordinates. (This
workflow is quite common when IFC models need to be issued to contractors who may federate
in Solibri/Navisworks/etc).

¢ Use the option “Export only elements visible in view” when used in conjunction with temporary
isolate/visibility/graphic override filters, to stop the IFC from exporting unnecessary data.

¢ Some design teams may require further information about the elements contained in the IFC.
This can be achieved by checking the option “Export internal IFC Property sets”. This will add
further IFC properties to each IFC element.

For more information about the options available in the GRAPHISOFT Revit Add-In, see http.//
tinyurl.com/hoe3fp9.
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Additional Steps for Revit MEP Model Export

Architects may not necessarily require all of the intricate fittings/components for coordination
purposes. Therefore, it is wise to hide these elements prior to export. This can be achieved in two
ways.

1. Temporary hide/isolate command

An easy way to isolate Ducts/Pipes is to use Revit’s temporary hide/isolate command. View the
Revit MEP model within a 3D View, highlight a duct, then use the sunglasses icon, followed by
“Isolate Category”.

Now, only ductwork is displayed in the 3D View; everything else will be temporarily hidden.

You can also select two different categories, e.g. Ductwork and Pipework, then use the Isolate
Category command to isolate elements of those types.

Apply Hide/lsolate to Vien

Hide Category

Isolate Element N .
Hide Element >

Reset Temporary b
110 BOGAGRART I RWm a8 <

2. Filters

Another way to isolate elements is to create filters. Filters can be created within Visibility/
Graphic Overrides (Press VG on the keyboard!)

A key benefit of filters is that you can create rules to show/hide specific elements. (With the
temporary hide/isolate command, it’s all or nothing.)

The screenshot below shows an isolated bathroom using filters to isolate the Revit MEP
elements.
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Visbiity/ Graphic Overndes for 30 View: Todet Room

Model Categores  Anvotaton Categores  Anslytosl Model Categores  Imported Casegones  Fiters

A cocument fiters are defned and oy

modded here

References

You can read more about Temporary hide/isolate and Filters in the following reference guides:

Temporary hide/isolate

https://knowledge.autodesk.com/support/revit-It/learn-explore/caas/CloudHelp/cloudhelp/2017/
ENU/RevitLT-DocumentPresent/files/GUID-ASE51D5E-8E18-4834-8A2F-8B4E3E6379A1-htm.html

Filters

https://knowledge.autodesk.com/support/revit-products/learn-explore/caas/CloudHelp/cloudhelp/
2015/ENU/Revit-DocumentPresent/files/GUID-B451C74B-9214-4974-9A49-2B46A9F6D822-
htm.html
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IFC Import into Revit

There are two ways to import an IFC file into Revit: Link IFC and Link RVT.

Link IFC

This option is recommended for inserting IFC models into the current Revit project as references.
You cannot edit the IFC model in Revit. If you later update the original IFC file, the Revit model will
reflect the changes when you reload the IFC file using Manage Links (Insert menu).

Read Revit’s Help for more information on this function.
BJ[Z}*EL';- Rr s - O A -2 BB

Architecture  Structure  Systems  Insert  Annotate  Analyze Massing & Site  Collaborate  View Manage  Add-Ins  Modify

;| BV L O

Modify| Improved | Link | Exportto Help
IFC Import] IFC JARCHICAD

Select « ARCHICAD Connection ~

Improved IFC Import and Link RVT

The “Improved IFC Import” command of the ARCHICAD Connection Add-In is recommended for IFC
import. There have been several recent improvements in this function.

For detailed information please see the manual here:

https://qraphisoft.akamaized.net/cdn/ftp/techsupport/downloads/interoperability/

GRAPHISOFT%20ARCHICAD%20Connection%20for%20Revit%202017.pdf

Here are the steps for the Link RVT:

1. First, import the IFC using the GRAPHISOFT Revit connection Add-In (Click the Add-Ins tab
followed by “Improved IFC Import”)

2. Save the IFC as an RVT file.

3. Open the main Revit model and click on the insert tab, followed by the Link Revit command.

A benefit of using Link Revit is that Rooms (ARCHICAD zones) can be seen when linked into the main
Revit model. If the converted Rooms cannot be seen, they can be shown with the help of the
following guide:

http://blogs.rand.com/support/2013/01/revit-cannot-see-the-linked-models-room-tags.html
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