Connexion   Inscription

Discussions & échanges

Toute question a forcément une réponse

  mardi 13 octobre 2015
  42 réponses
  18.5K vues
  Suivre cette discussion
Bonjour,

Je souhaite savoir et apprendre comment lorsqu'on a exporté une nomenclature depuis Revit vers Excel (jusqu'a tres facile), pouvoir completer les renseignements dans excel PUIS réinjecter tous ca dans Revit.
Je sais qu'il y a des plugin mais je cherche untuto ou quelqu'un qui expliquerai tout etape par etape.
Par avance merci
Sylvain
il y a environ 6 ans
·
#1722
0
Votes
Annuler
Dynamo le fait tres bien et gratos d'alleurs. Je vais essayer de prendre un peu de temps pour faire un tuto
il y a environ 6 ans
·
#1724
1
Votes
Annuler
il y a environ 6 ans
·
#1729
0
Votes
Annuler
Je vous en ai fait un rapide sur http://paris-rug.fr/
il y a environ 6 ans
·
#1731
0
Votes
Annuler
Super-Daniel !
il y a environ 6 ans
·
#1732
0
Votes
Annuler
Clair et rapide, merci Daniel.
il y a environ 6 ans
·
#1734
0
Votes
Annuler
Avec plaisir messieurs
il y a environ 6 ans
·
#1739
0
Votes
Annuler
pour ceux qui n'utilisent pas Dynamo, le plugin de chez Bim One fonctionne plutôt bien

Lien du plugin
il y a environ 6 ans
·
#1740
0
Votes
Annuler
Merci Floris, j'avais oublié celui-là !
quelqu'un l'as essayé ?
il y a environ 6 ans
·
#1742
0
Votes
Annuler
Le plug de BIMone a ses limite notamment par le fait qu'il ne gère pas les paramètres partagés ! (sauf amélioration récente)
Du coup quasi inutilisable pour des projets un peu conséquents où les paramètres partagés personnalisés sont indispensables.

Ideate BIM link très bien mais très cher

Le plus fournis (de ce que je connais) et le meilleurs rapport qualité prix et de loin, c'est l'ensemble des outils dédiés (Exel tools) des BONUS TOOLS de KIWI CODES. Si tu était venu au dernier PRUG tu aurais pu gagner une licence! 38 € 1 licence/an
il y a environ 6 ans
·
#1744
0
Votes
Annuler
Vincent Bleyenheuft a écrit:

Le plug de BIMone a ses limite notamment par le fait qu'il ne gère pas les paramètres partagés ! (sauf amélioration récente)
Du coup quasi inutilisable pour des projets un peu conséquents où les paramètres partagés personnalisés sont indispensables.


Je l'utilise actuellement sur mon projet et je gère parfaitement les paramètres partagés.
il y a environ 6 ans
·
#1749
0
Votes
Annuler
En aller simple oui mais aussi en retour avec modification depuis excel?
Si oui, c'est qu'ils l'ont amélioré depuis sa sortie, c'est une bonne nouvelle!
il y a environ 6 ans
·
#1757
0
Votes
Annuler
Vincent Bleyenheuft a écrit:

En aller simple oui mais aussi en retour avec modification depuis excel?


Oui pour l'export et l'import cela fonctionne.
il y a environ 6 ans
·
#1770
0
Votes
Annuler
Bonjour,
Merci pour toutes vos réponses.
Je change de pc demain donc j'attends pour installer vos differentes propositions et tester tout ca.
Ca me semble prometteur et on en a tous besoin dans nos projets.
Je vous ferai un retour asap.

Sylvain
il y a environ 6 ans
·
#2071
0
Votes
Annuler
a propos de la vidéo de daniel si l'on veut exporter non pas un paramètre mais deux, il faut faire deux Element.getparameterValuebyname puis une liste.create pour assembler les deux listes de paramètres et enfin un list.transpose pour mettre ces valeurs dans deux colonnes sous excel.
il y a environ 6 ans
·
#2118
0
Votes
Annuler
Salut Christophe,

Votre commentaire me laisse perplexe, j'ai plusieurs paramètres à exporter.
5 à 19 (X) selon la famille.

Si je comprends bien je dois créer X éléments get.parameterValuebyname ?

Si oui ce n'est pas du tout generative comme approche...
il y a environ 6 ans
·
#2120
0
Votes
Annuler
Non du tout, donc pourquoi pas poser la question avant de raler :)

Il suffit d'utiliser cette syntaxe dans le Code Block {"Level","Area"};

:)
il y a environ 6 ans
·
#2121
0
Votes
Annuler
Ne vous inquiétez pas je ne râle pas du tout, c’était juste ce que je comprenais du commentaires.

Une petite illustration pour ce Block {"Level","Area"} ? Merci d'avance...
il y a environ 6 ans
·
#2122
0
Votes
Annuler
Voila
il y a environ 6 ans
·
#2123
0
Votes
Annuler
Merci bien,

Est-il possible de récupérer de manière automatique tous les paramètres regroupés dans une catégorie ?

Par exemple dans mon cas la catégorie données contient toutes les informations à extraire.


J'ai mis en place votre code mais apparemment je n'arrive qu'a récupérer une seule information...


Merci d'avance
il y a environ 6 ans
·
#2124
0
Votes
Annuler
C'est possible de partager le fichier Revit?
il y a environ 6 ans
·
#2125
0
Votes
Annuler
Malheureusement non, il est confidentiel.

Je vais essayer avec un autre modèle que je peux partager.

Juste pour information pour la suite;
Est-il possible de récupérer de manière automatique tous les paramètres regroupés dans une catégorie ?

Je reviens vers vous avec un autre exemple dans le cas ou j'ai le même soucis.
il y a environ 6 ans
·
#2126
0
Votes
Annuler
Message à supprimer
il y a environ 6 ans
·
#2127
0
Votes
Annuler
Message à supprimer
il y a environ 6 ans
·
#2128
0
Votes
Annuler
J'ai le même soucis avec un simple cube.
Les paramètres: Longueur Largeur Hauteur et Volume.

A vous lire,
il y a environ 6 ans
·
#2129
0
Votes
Annuler
Ca devrait ressembler à cà
il y a environ 6 ans
·
#2130
0
Votes
Annuler
Merci Christophe, mais mon code est identique.

Je ne reçoit uniquement un seul élément.
il y a environ 6 ans
·
#2131
0
Votes
Annuler
bonjour,

quand tu mets des noms il faut faire extrêmement attention à l'orthographe
je te conseille de regarder les noms des paramètres avec la chaine SelectModelElement puis Element.Parameters puis Watch. Il faut faire attention aux majuscules et au accent, par exemple dans Room en français ce n'est pas Elevation mais Elévation. On a moins de problème quant on travaille avec un Revit anglais.
il y a environ 6 ans
·
#2132
0
Votes
Annuler
En plus si tu ajoutes des paramètres dans tes familles n'oublient pas de les charger dans ton fichier hôte via la boite de dialogue paramètres du projet . Un d'aller les charger dans paramètres partagés, deux de l'associer à ta catégorie.
il y a environ 6 ans
·
#2133
0
Votes
Annuler
Merci de prendre le temps de me répondre,

Petite précision:
-je n'ai aucun accent dans mes noms justement j'impose et je m'impose une charte textuel.
C'est très important dans mon work-flow de travail.
-j'essaie de récupérer des paramètres liés à un modèle génériques (voir image dans mon précédent mail)

- mon problème n'est pas lié à la récupération d'un paramètres mais lié à la récupération de plusieurs paramètres en même temps.

En plus si tu ajoutes des paramètres dans tes familles n'oublient pas de les charger dans ton fichier hôte via la boite de dialogue paramètres du projet . Un d'aller les charger dans paramètres partagés, deux de l'associer à ta catégorie.


Pour éviter ce genre de problèmes j'insère ma famille dans un nouveau projet à chaque fois.


Merci encore et espère trouver une solution à ce problème.
il y a environ 6 ans
·
#2136
0
Votes
Annuler
Christophe,
En suivant votre conseil:
je te conseille de regarder les noms des paramètres avec la chaine SelectModelElement puis Element.Parameters puis Watch

Je reçoit simplement le nom du cube (qui comporte d'ailleurs une majuscule, mais comme tous les paramètre de Revit), est-ce normal ? (voir 1ère image)
Je pensais que cela me listerais tous les paramètres de mon Cube...

PS:En import tout se passe bien je récupère bien une liste d'élément (voir 2ème image)
il y a environ 6 ans
·
#2137
0
Votes
Annuler
Rémy MAURCOT a écrit:
Je reçoit simplement le nom du cube (qui comporte d'ailleurs une majuscule, mais comme tous les paramètre de Revit), est-ce normal ? (voir 1ère image)

Salut,

le nom du bloc pour récupérer tous les paramètres c'est "Element.Parameters"
il y a environ 6 ans
·
#2139
0
Votes
Annuler
Merci Julien pour la subtilité, mais pourquoi je reçoit une seule valeur dans Element.GEtParameterValueByName ?

Pourtant j'ai vérifier plusieurs fois que la syntaxe était correct {"Longueur","Largeur","Hauteur","Volume"}:
dans le code Block

Inspirée du message de Daniel:
http://www.hexabim.com/general/question/nomenclature-vers-excel-puis-d-excel-vers-revit.html#reply-2122

Et j'ai aussi vérifier que dans le tuto vidéo il est bien question de Element.GEtParameterValueByName
Voir la vidéo à partir de 1:26 :
https://youtu.be/wRX2S642v7g?t=86

Merci d'avance
il y a environ 6 ans
·
#2140
0
Votes
Annuler
ca marche mais c'est Element.parameters et non Parametre.name
il y a environ 6 ans
·
#2141
0
Votes
Annuler
Rémy,

tu dois faire un clic droit dans ton nœud "Element.GetParameterValueByName" et dans la ligne "Combinaison", il faut modifier l'option.

PS: je n'ai pas Dynamo sous les yeux mais il me semble qu'il faut cocher "Produit vectoriel".

;)
il y a environ 6 ans
·
#2143
0
Votes
Annuler
Bonjour,

Dans mon cas l'export marche très bien, mais pour le ré-import de données modifiées, j'ai un message d'erreur "appel ambigu....." cf photo en PJ

Si qq un a une idée
Merci par avance

Pierre
il y a environ 6 ans
·
#2145
0
Votes
Annuler
Cependant le ré-import marche très bien en ne sélectionnant qu'un seul élément. (pas avec 1500 fenêtres)
il y a environ 6 ans
·
#2148
0
Votes
Annuler
Salut pierre,

est-ce que c'est possible de voir le prog dynamo en entier ?
Quel est ta démarche entre Revit et Excel ? Quel opération essaye-tu (import de paramètre, création de feuille,....) ?
il y a environ 6 ans
·
#2149
0
Votes
Annuler
Salut

Ma démarche consiste à voir s'il est possible de remplacer les nomenclatures de Revit par Excel (comme sur Allplan) via Dynamo.

Je t'envoie le prog en entier.

Merci.
il y a environ 6 ans
·
#2195
0
Votes
Annuler
Charles PIRO a écrit:

Rémy,

tu dois faire un clic droit dans ton nœud "Element.GetParameterValueByName" et dans la ligne "Combinaison", il faut modifier l'option.

PS: je n'ai pas Dynamo sous les yeux mais il me semble qu'il faut cocher "Produit vectoriel".

;)


Merci Charles, c'était bien la solution à ce petit problème.
il y a environ 6 ans
·
#2211
0
Votes
Annuler
Le seul but du Element.Parameter est de voir quel parametre sont accesible par Dynamo.
Si les parametres recherches ne sont pas disponible dans ce Node il faut voir pourquoi
il y a environ 6 ans
·
#2213
0
Votes
Annuler
Merci Daniel, j'ai bien compris le principe.
Mon problème venait de l'option "produit vectoriel".
il y a environ 6 ans
·
#2216
0
Votes
Annuler
Tu dois changer le lacing a Cross-Product pour avoir toutes les valeurs de toutes les elements
Cette discussion ne contient encore aucune réponse.
Soyez le premier à y répondre !