Connexion   Inscription
  lundi 3 février 2020
  13 réponses
  1.4K vues
  Suivre cette discussion
Bonjour,

je m'explique...
j'ai créé des familles il y a qq mois, mais tous les paramètres ne peuvent pas se rajouter dans les nomenclatures.
ces paramètres ne sont pas en "partagés" dans la famille et sont donc en "grisés" donc non modifiables.

Est ce qu'il y a un moyen de modifier autrement (oui... il y a des formules dans les familles....)

les diamètres des canalisations, par exemple, sont spécifiés dans les différents types(dans le nom) de la famille que j'ai créé pour un projet, mais du coup ne sont pas dans la colonne des diamètres contrairement à d'autres...)
Merci de votre aide!encore!
il y a environ 2 ans
·
#13526
0
Votes
Annuler
Bonjour,
Je vous mets un exemple de ma nomenclature, ci-joint.
pour les consoles, ça marche.. mais les colliers poire, pas de DN dans la nomenclature, et pareil pour les 2 familles chaises, pour DN, largeur et hauteur...
svp!!!
il y a environ 2 ans
·
#13536
0
Votes
Annuler
Bonjour,

Dans un premier temps je vais vérifier si j'ai bien compris votre problème :
Vous avez des famille dont certain paramètre (qui ne sont pas partagé) doivent être inclue dans les nomenclature. C'est bien cela ?

Si oui, je vois deux méthodes pour gérer votre problème des paramètres non présent dans la nomenclature :
- Modifier les paramètres en les passant en paramètre partagé, le fait d'avoir des formules ne devrais pas poser de difficulté. Cependant je conseil de copié les formules au cas où. C'est la méthode que je conseillerais. Dans ce cas, les paramètres sont visible dans les nomenclatures et les formules sont préservé.

- Ajouter des paramètres partagé avec les noms qui vous intéresse et utiliser la formule "=[paramètre à copier]". Cette méthode ne nécessite pas de copier les formules mais sera plus lourde.

Bien sure si j'ai mal compris votre problème, n'hésitez pas à me le réexpliquer pour que je puisse mieux vous aider.

Raphaël
il y a environ 2 ans
·
#13537
0
Votes
Annuler
Bonjour,
oui, vous avez bien compris.

la 1ere solution n'est pas possible, si je passe les paramètres en paramètre partagés, je ne peux pas valider.. c'est en grisé (apparemment c'est à cause de la formule de ce que j'ai vu sur internet).
Je vais essayer cet aprem la 2eme solution... mais ca correspond à quoi la formule =paramètre à copier.
Merci de votre réponse.
il y a environ 2 ans
·
#13538
0
Votes
Annuler
Alors pour la première solution, il y a une possibilité : coupé la formule, passer le paramètre en paramètre partagé puis recoller la formule

Pour la seconde solution, la formule =[paramètre à copier] permet au paramètre partagé d'avoir la même valeur que le paramètre d'origine cela limite le nombre de calcule et réduit ainsi les temps de traitement lié à ce paramètre.
il y a environ 2 ans
·
#13540
0
Votes
Annuler
Bonjour,

Tout d'abord, petite précision sur vos propos du premier message :
ces paramètres ne sont pas en "partagés" dans la famille et sont donc en "grisés" donc non modifiables.

Si la valeur d'un paramètre de famille n'est pas modifiable dans un projet, ce n'est pas parce qu'il s'agit d'un paramètre de famille (et non d'un paramètre partagé) mais parce qu'il fait intervenir des formules de type conditionnelle et/ou qu'ils fait intervenir au moins deux autres paramètres (ou parce qu'il a été verrouillé par d'autres moyens).

Ensuite, la première solution, proposée par Raphaël Blaiteau fonctionne couramment très bien :
Depuis la fonction "Type de famille", lorsque vous êtes dans votre fichier famille, sélectionnez le paramètre à "transformer" en paramètre partagé, cliquez en bas sur "Modifier le paramètre" et créer un nouveau paramètre partagé, qui remplacera l'ancien.

Attention cependant : Si ce paramètre intervient dan des valeurs calculées d'autres paramètres, alors ce nouveau paramètre partaggé doit être écrit exactement de la même manière que celui qu'il remplace (majuscules/minuscules, espaces, caractères spéciaux, accents) et répondre au même type (longueur, texte, oui/non, etc.).

La seconde solution de Raphaël Blaiteau consiste à créer un nouveau paramètre qui sera un paramètre partagé, en plus de celui que vous avez déjà créé. Vous auriez donc, par exemple, dans la famille S1 COLLIER POIRE.rfa, deux paramètres pour la hauteur, deux paramètres pour le diamètre nominal et deux paramètres pour la largeur. En utilisant la colonne des formules de calculs, vous faites en sorte que le paramètre partagé soit égal à son homologue non partagé. Et comme il n'est pas possible d'avoir deux paramètres qui portent le même nom, votre nouveau paramètre partagé devra porter un autre nom.

Exemple, avec H (paramètre de famille) et H1 (paramètre partagé) :
H1 = H

C'est une solution simple mais qui double le nombre de paramètres.

Sinon, est-ce qu'il est possible d'avoir une famille à mettre à jour, pour faire des tests et vérifier ce problème lié à la solution 1 ?
il y a environ 2 ans
·
#13560
0
Votes
Annuler
Bonjour,

Merci de vos réponses!!
désolée, je n'étais pas disponible pendant ces 2 jours!
je vais regarder tout ça très vite!!!

oui, je vous mets en pièce jointe la famille collier poire.
Merci!!!
il y a environ 2 ans
·
#13562
0
Votes
Annuler
Bonjour,
Je viens de tester le remplacement des paramètres d'origine par des paramètres partagés. Cela fonctionne très bien (pas de message d'erreur, pas de rupture dans les formules).

Fichier de paramètre partagé et famille à jour, en pièce jointe.
il y a environ 2 ans
·
#13563
0
Votes
Annuler
Haaa je peux pas l'ouvrir!!! je suis sur 2018!!!!!! :( :( :(
il y a environ 2 ans
·
#13564
0
Votes
Annuler
Haaa j'avais oublié ! je la reposte dès que j'ai un créneau. Cependant, la seule chose faite, c'est l'association de paramètres partagés en lieu et place des paramètres de famille.
il y a environ 2 ans
·
#13565
0
Votes
Annuler
ok merci!!!
ca me permet déja de voir ce que je dois faire sur les autres familles aussi!!
il y a environ 2 ans
·
#13584
0
Votes
Annuler
Bonjour,
vous pourrez le renvoyer svp en 2018?
Merci!!
il y a environ 2 ans
·
#13587
0
Votes
Annuler
j'ai testé pour refaire des paramètres partagés... c'est toujours en grisé...(dès que je clique sur "paramètre partagé"sur l'ancien paramètre,ca devient gris"et si j'en fais un nouveau.. pareil)
il y a qq chose que je dois mal faire....
il y a environ 2 ans
·
#13593
0
Votes
Annuler
C'est bon.. j'ai trouvé le souci.. j'avais un fichier texte lié que je ne pouvais pas mettre.. maintenant tout est ok! mais au cas ou je veux bien qd même voir le votre quand vous pourrez, pour vérifier merci!!!
Cette discussion ne contient encore aucune réponse.
Soyez le premier à y répondre !
Le Cron démarre